WhiteHatBox
Share Page
Following(0)
Partner(s)
kameo2k

error code:-1073741819

ReplyThanks 2020/01/08 17:17:17 0 0
Got the new version of botchief (4.8.3.1) and compiled my bots but now they are crashing by themselves after ~20 minutes with this error code:-1073741819. I check the debug log and it isn't showing an error nor is the bot showing an error when it craps out. It just stops...doesn't matter what command it is on at the time. What the hell is this error code? And why do botchief updates seem to break more than they fix >.>
Aprilcaicai
2020/01/09 13:38:15

Try to run your module with New Window in BotChief Editor, and see if it can run well.


I have informed our programmer to check and test it in our side too, please wait for the news.


We are so sorry for the inconvenience.

Aprilcaicai
2020/01/09 14:02:47

A few questions need your answer:

1, which browser did you use to write your module in Editor? Geckofx29?33?45? or Chrome?

2, Is the BotChiefDebug application crashed? Can you provide the details?

3, Is the same issue happening in each run? How about re start your bot, can it run well?


Waiting for your news.

kameo2k
2020/01/09 21:46:37

Aprilcaicai,


1. The bot is written in Gecko45 and Gecko60. I have tried both with the same results.


2. The BotChiefDebug is what is crashing. I also noticed it normally happens roughly when the debug log file gets to be about 100KB and then it tanks. The bots run on a completely standalone machine with nothing else running in the background.


3. The same thing happens every run. At about roughly 20 minutes of continuously running the bot crashes with the error code mentioned above.


These bots were running without an issue before I updated (changed login process on a website) and compiled them with the newer version of botchief. I can't roll back the version because I was on a version much earlier than 4.8.3.1.

Googled the error code and some folks are saying it has something to do with sound drivers but my bots don't use any sound and my drivers are up to date. Restarting these every 20 minutes is starting to become tedious...I could send you guys a bot to take a look but it holds sensitive passwords so I would rather not go that route if possible.

Aprilcaicai
2020/01/13 10:14:41

Thanks for your reply,


I have forwarded it to the programmer. We understand, i will talk it with the programmer. Any news from them, i will let you know.


So sorry for the inconvenience.

Aprilcaicai
2020/01/13 11:51:17

Can we arrange a time to help you check it via remote connection? My Skype id is: live:whitehatbox you can leave me a message on Skype with your question attached, so i can know who you are.


Waiting for your news.

Aprilcaicai
2020/01/17 14:41:20

Update


We just made an update for the software, please update it to the latest version to check if your issue can be solved.


Waiting for your news.

kameo2k
2020/01/25 06:58:46
That worked! Seems to be running just fine now after compiling the module again after the update.

I do have another question though. Is it possible to have a module complete an action when it receives an error and closes? Like as it is crashing to send the error code to an email address? Thanks!
<< < 1> >>
VerifyCode
Advanced Option